EXCELsexy anauk.net
Niedziela 22. Maja 2022r
Wiesława, Heleny 
Nadawanie Nazw Komórkom i Grupom Komórek
Podczas pracy z arkuszami często wpisujesz adresy komórek, które odwołują się do określonej komórki lub zakresu komórek (na przykład Arkusz2!A3:D5 ). W programie Excel możesz nazwać te komórki, aby lepiej opisać ich zawartość. Na przykład łatwiej jest zrozumieć notację:
=SUMA(koszt)/miesiąc
niż
=SUMA(B3:B14)/D5
Nadawanie nazwy komórkom
Spójrz na poniższą tabelę. Podano nazwiska trzech osób oraz liczbę godzin, które przepracowały każdego dnia tygodnia.
Załóżmy, że chcesz wybrać wszystkie godziny przepracowane przez mężczyzn naraz, bez za każdym razem ręcznego wybierania komórek.
Przykład 1:
Zaznacz komórki od C3 do G3, a następnie, trzymając wciśnięty klawisz Ctrl, zaznacz komórki od C5 do G5. Po wykonaniu tej czynności wpisz tekst "Mężczyźni" w polu nazwy.
W naszym przykładzie mamy tylko jedną kobietę. Aby utworzyć dla niej nazwany zakres, zaznacz komórki od C4 do G4 i tym razem wpisz "Kobieta" w polu nazwy.
Automatyczne zaznaczanie wielu grup komórek
Załóżmy, że chcesz wybrać godziny pracy dla każdego dnia osobno. Możesz to zrobić w podobny sposób, jak w przypadku "Mężczyzn" i "Kobiet". W takim przypadku musiałbyś dokonać pięciu wyborów dla każdego dnia osobno. Jednak, aby przyspieszyć ten proces, możesz stworzyć je wszystkie na raz.
Wybierz komórki od C2 do G5, a następnie przejdź do FORMUŁY >> Nazwy zdefiniowane >> Utwórz z zaznaczenia.
Pojawi się okno Tworzenie nazw z zaznaczenia, których komórek chcesz użyć jako nazw. W naszym przypadku będą to komórki z górnego wiersza.
Kliknij OK, a następnie strzałkę w polu nazwy. Znajdziesz tutaj dwie grupy, które utworzyłeś wcześniej: "Mężczyźni" i "Kobieta", a także grupę godzin na każdy dzień tygodnia.
Wybór grup komórek
Istnieje kilka sposobów na wybranie wcześniej utworzonych grup.
Przykład 2:
Pierwsza metoda polega na wpisaniu nazwy grupy bezpośrednio w komórce.
  • UWAGA
  • Jeśli wpiszesz nazwę = Mężczyźni, program Excel zwróci błąd, ponieważ nie możesz wpisać do jednej komórki wielu komórek. W takim przypadku możesz użyć ją w funkcji.
W tym przykładzie użyjemy funkcji SUMA do obliczenia sumy godzin przepracowanych przez mężczyzn. Gdy zaczniesz wpisywać formułę i dojdziesz do "=SUMA(Mę" , Excel wyświetli wskazówkę.
Aby zaakceptować tę grupę, kliknij ją lub użyj klawisza Tab.
Przykład 3:
Drugim sposobem jest wybranie grupy z FORMUŁY >> Nazwy zdefiniowane >> Użyj w formule.
Przykład 4:
Trzecią metodą jest Wklejanie nazwy. Naciśnij klawisz F3. Gdy pojawi się okno, wybierz zakres z listy.
  • UWAGA
  • Jeżeli przeniesiesz wszystkie komórki znajdujące się w danej grupie, Excel zapamięta ich nową pozycję. Jeśli jednak przeniesiesz tylko ich część, program Excel nie będzie mógł ich wybrać, gdy wybierzesz pozycję z pola nazwy.
Menadżer nazw
W menedżerze nazw możesz zarządzać grupami. Możesz je dodawać, usuwać i edytować. Aby użyć Menedżera nazw, przejdź do FORMUŁY >> Nazwy zdefiniowane >> Menedżer nazw lub użyj skrótu klawiaturowego Ctrl + F3.